email alert

rdyrnotrdyrnot
edited January 2015 in InfraSensing Sensors
I just received my sensor gateway and email alert is not working.



We use are own internal mail relay server. I can ping the mail our relay server and the setting in the sensor gateway are the same as my previous sensor gateway.



All I get after sending test email is: Test email can't be sent.



Is there some log file available to help me troubleshoot.


«1

Comments

  • AdministratorAdministrator
    Is your previous unit's email function working with the same settings?
  • rdyrnotrdyrnot
    I changed it to one of our another smtp server listservsmtp.ntca.org. I reviewed the settings and it looks good. I can ping the sensor gateway from the smtp server. Emails are not getting to the smtp server (I checked logs on it).



    Both the sensor gateway and listservsmtp are outside our network so I can monitor temp. from mobile device.



    Again, are there logs somewhere on sensor gateway that I can review? All I see is the alert log.



    On another note: I completed the cloud setup for the sensor gateway. I entered the device settings id and pin. It shows as offline? When I hit update in the cloud section, it says it updated successfully but when I log on to the cloud portal site the device NTCA-Arlington shows as offline. Until I can resolve the smtp connectivity issue I was hoping to setup alert using this.



    Any ideas?



    Tim
  • AdministratorAdministrator
    No there are no logs for the sensor gateway. If it is an internal mail server you could check the mail server's logs. Alternatively you could try using Gmail



    For support of the cloud platform kindly post it in the correct forum. Support for cloud and software is only community based as those are free products. Commercial support is available for those products.
  • AdministratorAdministrator
    Have you tried using a Gmail address, for example, for the alerts? What's the result?



    For Cloud connectivity, make sure first that traffic from SensorGateway outbound to TCP 443 is opened.
  • I have been watching this post with interest as I too have the same issues with devices with firmware v4 or above.

    The strange thing I could not work out is why 14 devices worked and that I had hit an miss success with everyone I tried.

    During a recent new office build I managed to get the network team to run a few tests for me.



    During the email test process / alert sending

    V3.06 firmware sends a SYN with a Window size of 1536 and connects to exchange successfully. The V4 and above firmware sends a SYN with a window size of 384 which exchange doesn’t like and so never successfully transmits any data.



    This explains why I have some success as the working devices are behind silver peak devices, which must be fixing the issue.



    as to the comments above that i should use Gmail. This is a non starter due to security restrictions and owning the process end to end.



    Can we please have the correct setting put back as it seems this affects a lot of people who want to manage the solution end to end and not use Gmail as we can not guarantee the delivery of the alerts.



    This is stopping about 70 devices being added to the cloud and is therefore a big issue to me and my company.





    thank you










  • AdministratorAdministrator
    Thank you for clarifying the issue.



    We have passed it on to our development team for consideration.


  • [Deleted User][Deleted User]
    Hello,

    I've the same problem.

    after upgrade to 4.x firmware I'm unable to change email server address.

    5.x firmware have the same problem.



    please, fix this problem. :-)


  • AdministratorAdministrator
    MicroT your issue is not same as reported. You are stating that you can't change the email server address. The issue of this thread is a SYN size issue
  • [Deleted User][Deleted User]
    I think it is the same problem because after email address change, automatic email test fail with message "test email can't be sent".

    but email server is ok. it is the same used before (ibm domino). only ip address of email server is changed.

    the only change is the upgrade to 4.x firmware, and now 5.x firmware.

    maybe the syn change with 4.x firmware have broke email test with some email server.
  • AdministratorAdministrator
    that's still very different to your issue of not being able to change the email server address. kindly do a factory reset and test again
  • [Deleted User][Deleted User]
    take a look on first post of this thread: the error is the same.

    is the same problem.

    take a look on the third post: is the same problem!

    I've no time to reset sensors. I've to change email server, a simple change of one ip address.

    with 3.x firmware I've chenged email server without any problem. after 4.x firmware is not possible.

    I've tried to insert ip address of 2 domino servers and 2 linux box. does not work. the error is the same: "test email can't be sent" and there are no log on every email server that I've tried.
  • AdministratorAdministrator
    Dear Bern & Rdynot,



    Please try following TEST build of the firmware to see if that resolves the issue you reported:

    http://downloads.serverscheck.com/sensors/FACTORY_HWver5_Fw_Release5_11.bin



    This update will only work on Base units starting with Serial number 2013 or 2014 !
  • BernBern
    Hi there



    first of all thank you for looking into this However.

    This does not seem to fix the issue. The email still fails

    All my devices have been purchased in the last 2 years.

    as the serial number is behind the device is there a way of getting it off the device with a command?

    The window size must still be not big enough or there is still a difference between v3.06 and the new ones.

    what window size has now been set during the email negotiations.

    its works with external smtp servers like port80.smtpcorp.com but not with the internal exchange servers.

    As the main purpose is to keep the whole process in house as we can guarantee service this is causing us the issues.

    I am available to test anytime

    thanks



    B
  • AdministratorAdministrator
    B, kindly let us know what SMTP port for sending you are using so that we can pass it on to our development
  • BernBern
    Hi there

    port 25



    if you send me an email to use I will send you the capture files
  • AdministratorAdministrator
    Please send it to files at serverscheck.com and refer to this forum post
  • BernBern
    Did you get the files?

    is there anything else you need?
  • AdministratorAdministrator
    Yes we got it. It was post on to our R&D team
  • BernBern
    Hi there

    please can I have an update on this

    they have had the files a while now



    thanks



    B
  • AdministratorAdministrator
    it is still with our R&D team
  • AdministratorAdministrator
    We found an issue in the authentication with Exchange which uses GSSAPI or NTLM for authentication.



    The SGW currently (and previously) onlu supported base64 decoder plain text or SSL
  • BernBern
    Hi

    does that mean you have found the change made since v4 that is stopping emails ?

    when can I test?

    i have units ready to deploy a test build to if you have one



    thanks



    B




  • AdministratorAdministrator
    Bern,



    what authentication method are you using on Exchange?



    NTLM has never been supported to date.
  • BernBern
    It has always worked on v3.06

    It also works on later versions if the sensor is behind a silver peak device



    I sent the logs

    It's the window size in the negotiations you have changed
  • AdministratorAdministrator
    Bern



    what authentication method are you using on Exchange?



    NTLM or GSSAPI or none?
  • BernBern
    I believe none



    No boxes are ticked on the severscheck devices and no passwords or usernames used.

    The only requirement is an email address In The from field
  • BernBern
    If v3.06 works the it's not authentication



    I will resend to your files email address the screen shots of the transmissions
  • AdministratorAdministrator
    OK. So issue is Exchange WITHOUT authentication.



    We'll pass the info onto our R&D team.
  • AdministratorAdministrator
    Bern,



    we have done several tests over the past week with Exchange 2013 WITHOUT authentication using firmware 3.06 and firmware 5.11



    We used Exchange on port 587 without SSL.



    In both cases it is working just fine, emails are received.


  • BernBern
    Hi there



    although I am glad it works for you, this does not fix mine and a few other peoples problems.



    As I said port 25

    No authentication



    if it works on v3.06 and not on any newer version then something has had to change. your side not mine.

    I sent the windows sizes data and screen shots to your file email address. Please can you look at them. I can resend if you need them..

    please check what code was changed as something obviously did as i can go to v4 or 5 or 5.11 and it does not work then back to 3.06 and it works.

    only if I use a silver peak can i get the later version to work. this is obviously happy with what ever you changed, but a seriously expensive solution for me.



    if you need testing I can do this any time.

    if you want to send me some code to test i can do that too.



    thanks



    B
Sign In or Register to comment.