SNMP Trap is not woking (it seems)

Hi Admin,

I am trying to capture the SNMP trap from the sensor gateway (using Manage engine MIB Browser free tool) just to see how the trap message is generated from the sensor gateway. The "Trap Viewer" is listening on port 162 with community string as "public1" (which is the same as I set in the sensor gateway), but I am not getting any response from the SG during the alarms. Please let me know what is wrong in my process.

Any help is appreciated

Comments

  • Check first if you have the latest firmware installed. Are you able to do an SNMP walk? Then verify that the "SNMP Trap" checkbox is ticked on the sensor status page in the SensorGateway web interface. Another thing to look at is if you are using the same version of SNMP set both in the SensorGateway and your trap viewer settings, as well as the ports that they are using. Also verify the correct IP address of your trap receiver that is set in your SensorGateway. Another possible issue is like when using a different MIB Browser (I use iReasoning-can be downloaded from the serverscheck website), there is a button that you must press to start the Trap viewer to listen for trap alerts.
  • Hi Zero,

    I am able to do the snmp walk.

    I did all the above and double checked it. Still no response received from Gateway.

    I tried using iReasoning and Manage engine MIB browsers, both of them are not getting the messages from SG.

    Any help would be appreciated
  • Hi,

    For iReasoning, double check if the trap settings are also correctly set up. Usually this is missed, but it can be accessed by opening the trap receiver (Tools->Trap Receiver), then you can find a small icon with a wrench in it. This will open the Trap Receiver Settings, and from there verify all information is correct under "General" tab. Leave "Forward traps to" blank.

    Then in the SG Sensor Menu, under SNMP, "Enable SNMP Traps" check box must be active, and once again verify the Trap version, Trap IP(IP of computer you are using), the trap port (must be different from SNMP agent port) as well as the community string. Then click submit to save changes.

    Now under "Sensor Status" from the Sensor Menu, verify that "SNMP Trap" checkbox is ticked, then click on Update to save changes.

    Trap alerts should be working at this point and if not, please you post your settings for both the SensorGateway and iReasoning. Also check the user manual(Download from https://serverscheck.com/support/manuals.asp) for additional info.

Leave a Comment

bolditalicunderlinestrikecodeimageurlquotespoiler