Error - Unable to retrieve data


I am having trouble login onto the iOS app. It gives the following error: Error - Unable to retrieve data. I have been able to use this app for the last 5 months and am able to login with the same details into the online cloud platform, but for some reason it has stopped working.

Could you please advise.

Kind regards



  • AdministratorAdministrator
    edited June 2015
    have you tried deleting the app and then download it back..
  • chonkiechonkie
    I did. It still gives me exactly the same error.
  • skibromontskibromont
    Same here: IPhone 6, IOS 8.3. I had the same error at the original install. Deleted and downloaded again and still the error message.
  • AdministratorAdministrator
    this has been escalated to serverscheck devs and their currently working on the fix for the app
  • AdministratorAdministrator
    The iOS issue has been fixed.

    Here is what caused the issue:
    It appears that Apple changed something in their security root certificates which caused the ServersCheck certificate no longer to be accepted. Android apps pointing to the same servers and certificates did not have that issue. We had to change our architecture and get new certificates issued in order to resolve the issue. The fix does not require you to change anything in your app.
Sign In or Register to comment.