Infrasensing wireless temp/humidity sensor integration into Niagara

I am having problems configuring the points for an Infrasensing wireless temp/humidity sensor in Niagara N4 over Modbus TCP.

I have the points set up as Floating, and the devices set up as follows:
Gatewaysensor: Node 0, Register Value 30201 - This reads OK
Temp Sensor 1: Node 1, Register Value 33233 - This reads OK
Temp Sensor 2: Node 2, Register Value 33265 - This reads OK
Temp/Humid Sensor: Node 3: humidity register value 33297 - this reads OK; Temperature Register Value 33296 - This is NOT reading correctly.

The temp reading fluctuates wildly from an extreme negative value to 0, and occasionally hits the right temperature.

The sensor reads correctly when I log directly into the sensor web configuration via my browser, just not in the Niagara software. I've attached images of both what I'm seeing in the web configuration and in Niagara.

Can someone help me get the right register values assigned to the Temp/Humidity sensor?

2018-09-26 07_52_56-ServersCheck SensorGateway Web Configuration
2018-09-26 08_21_54-CBRE Niagara4 Workbench


  • Additional image to show the temperature/humidity readings in the sensor web configuration:

    2018-09-26 08_32_46-ServersCheck SensorGateway Web Configuration
  • todd_johnston

    Temp/Humidity sensors has 2 different sensor types. One is the Temperature and one is the humidity, even if they are just in one sensor. So it takes up 2 nodes.

    You have not read the points correctly as you skipped your first wireless sensor.

    This should be the correct points for your sensors.

    Internal Temp (Node 0) - 30201
    Wireless A (Node 1) - 33201
    Wireless B (Node 2) - 33233
    Wireless C-T (Node 3) - 33265
    Wireless C-RH (Node 4) - 33297

    So if you have additional sensors connected, this should take the next nodes and so on... so you only need to add +32 for each previous input register.

    Let me know if it worked.


  • Thank you Char, this solved my problem.

    It appears that the Modbus integration manual has the wrong input register value listed for Node 1...

Sign In or Register to comment.