ST6105J Thermometer

edited April 2006 in InfraSensing Sensors
I have just received a ST6105J Serial Port Thermoter. I have installed Servers Check version 6.3.3 Standard (Freeware) and have connected to thermometer to Com1. I have been receiving "Unable to open Com1" after setting up the monitoring rule. I have tried setting this up on 3 different computers all with the same error. .Net Framework is loaded with latest service pack. Please Help.




  • AdministratorAdministrator
    Is COM1 available?

    Is not being used by a modem or modem related app?
  • AdministratorAdministrator
    Can you start following from the command prompt (in the "agents" subdirectory of the ServersCheck Monitoring Software):

    sensorsoft_check -L log.txt -C COM 1

    and send me the output

    Note that we also recommend upgrading to 6.3.4 as per release notes.

    You can download the latest version or use the update.exe to upgrade. In some situations the update.exe might fail (typically when not all ServersCheck services are stopped) or the newly installed version might not run correctly. In such situations please perform the upgrade as outlined on following url:
  • tpippentpippen
    COM 1 is available. I've tried this on 3 computers with the same result. I will upgrade now and send you the output of the test above.


  • AdministratorAdministrator
    Send me the output of the command line app so that we have a bit more debugging info.

  • wolfchwolfch
    I have exactly the same problem. I tried it also on three machines. Sometimes it works, sometimes not. When I try to start the agent per hand as described, it works fine. Afterwards the GUI also says OK. After some hours the COM Port cant be opened. I use version 6.4.0

    sensorsoft_check -L log.txt -C COM 1

    Processing command read all

    Device Model = ST6105

    Device Status = Normal

    Firmware Version = 3.22

    Number of variables = 3

    Variable 1: TEMPERATURE (0.5 C RESOLUTION) 25,5 C

    Variable 2: TEMPERATURE (0.1 C RESOLUTION) 25,5 C

    Variable 3: HASH ID 53750
  • AdministratorAdministrator
    What is the interval? Is it a dedicated machine with no other com device on it?
  • wolfchwolfch
    The interval is 60 seconds, and there is nothing else connected to this machine. As I described I tried this on three different machines, always the same. Sometimes it works, sometimes not. Its always Windows 2003 Server.

    While I write this I have the failure again. Unable to OPEN COM Port. Alse when I try manually with sensorcheck
  • wolfchwolfch
    Is there a way to try it with HyperTerminal to see if the COM port is the problem or your agent?
  • AdministratorAdministrator
    Does restarting the service solve the issue or is a reboot required? It is really critical knowing if the service restart solves the issue or if it requires a reboot.

    Also what is the number of retries you set?

    Or does the issue disappear after a few minutes?

    Our demo server (the one that you can see on our website) uses a serial one on Windows 2003 server/ It never produced the issue you reported making us think that it might be configuration related of the OS.
  • wolfchwolfch
    The issue diappears after some time. The next time it didnt work I try to restart the service and look if it works immediately after the restart. I do not think its OS dependent, because I tried on threee different machines, always with a blank win2003 server. Is it possible that the sensor is defect?
  • AdministratorAdministrator
    What is the number of retries you set and the retry interval?

    It is nearly impossible that it is related to the sensor.
  • wolfchwolfch
    Number of retries = 1, interval 60 seconds
  • AdministratorAdministrator
    See document that came with sensor:

    number of retries has to be 3 with retry interval 180 seconds
  • wolfchwolfch
    Oh sorry I didnt read that. I will check it with this new settings fpr the next days, and give you feedback here
  • wolfchwolfch
    No change, always the same. Down for some hours, and then up for 12 minutes

    status of TEMPERATURE () changed to DOWN at Thu Jun 22 14:48:39 2006. Reason: Error: Unable to open COM port 1

    status of TEMPERATURE () changed to OK at Thu Jun 22 14:37:17 2006. Reason: Recovered from last error: Unable to open COM port 1
  • AdministratorAdministrator
    Can you let it run in debug mode as per knowledge base and copy the debug output.
This discussion has been closed.