Ping Watchdog feature

Is it possible to have the ServersCheck reboot if a ping fails? Sometimes these devices power up on our switches before the switch's 802.1x process has started, so they sit in a down state indefinitely and don't appear to restart the DHCP process. A watchdog feature would alleviate the issue.

Comments

  • JeanMeyerJeanMeyer
    Hi, I would like to second this request, would be very useful not to have to remember to reboot the Gateway once a week. Currently I need to reboot my 2 Gateway's once a week as on a Monday morning when we get to work, they will not respond or allow web access.
  • DhaneDhane
    May I ask what switches are you using?
  • JeanMeyerJeanMeyer
    Hi, sure, I am using Dell PowerConnect Switches.
    May I ask why?
    Thank you!
  • DhaneDhane
    edited April 6
    Because I haven't got this issue and my base unit are running for months now without the need to reboot.
    I am using a D-link PoE switch and a Linksys PoE switch.
    As I am thinking this may also be an issue.
    And did you setup the SGW network? Although mine has been Fixed IP from the start.
  • JeanMeyerJeanMeyer
    Hi, thanks for the information, Both my Gateways has Fixed/Static IP's. I will still try a POE injector on a different Layer2 Switch as a test. I do not think the POE is the issue, they are not rebooting, they run fine, just at some point I lose access to them from the network. My one Gateway is the older one stuck on 5.11 firmware and the other a later unit with the latest firmware on. I just checked and the newer one is off-line for the 3rd time this week.
  • DhaneDhane
    Yes please do share your results. Hopefully good outcome on your test
  • AdministratorAdministrator
    JeanMeyer your issue is different from that of Dr Fahrenheit. His issue is that the Sensorgateway reboots faster than his DHCP server resulting in the unit not getting an IP address. Critical applications should have a fixed IP.

    Regarding your issue can you confirm what is not responding? SNMP, Modbus TCP or HTTP ?
    What sensors are connected to your Sensorgateway?
  • JeanMeyerJeanMeyer
    Hi, apologies for the late reply, yes, mine seems to be different, but I thought it could be solved in the same way, hence I was trying to help motivate it. I have moved my Sensor Gateway from a Layer 3 POE switch to a smaller Layer 2 HP Switch with a POE injector. The thinking would be that something would stop HTTP from responding. I have 2 gateways running currently, the older one one has 2 sensors connected the newer one has a hub with 4 humidity sensors plugged in currently. We have 4 more to plug in. Both are showing similar behaviour the display on the sensor shows it is working, but the HTTP access stops working. Manual Reboot brings HTTP access back.
  • JeanMeyerJeanMeyer
    The older unit has a humidity and power sensor on it.
  • AdministratorAdministrator
    Based on what you are saying, it had no issues in the past but only when you changed the PoE switch. It looks like something on your switch may be causing a conflict not enabling you to access the web interface of the device. As the 5.11 used to work fine for many years. In that time the only thing that seems to have changed is the switch.
  • JeanMeyerJeanMeyer
    Hi, not quite, I moved it from my POE switch where I was having an issue onto a Layer 2 Switch with less intelligence and the problem persist. I cannot say for sure how long this been happening as we have only noticed it now that we are retrieving data from the unit and the is how we noticed it literally goes off 2 times a week.
  • JeanMeyerJeanMeyer
    Hi, any additional feedback on this?
  • AdministratorAdministrator
    JeanMeyer

    1/ What firmware are you running on your units?
    2/ What protocol are using to access the sensors' data?
  • JeanMeyerJeanMeyer
    Hi, thank you for the reply:
    1. We are on 8.7, just downloaded 8.8 and installed, but the sensor did not come back up, will go check on location what it is doing.
    2. Our app pulls data from a REST server on the Sensor currently.

    Thank you
  • JeanMeyerJeanMeyer
    Had to Reset back to factory as 8.8 update failed. All back now:
    Hardware VersionRelease 5.1
    Firmware VersionRelease 8.8 (May 18 2022)
  • JeanMeyerJeanMeyer
    No Feedback on this item?
Sign In or Register to comment.